Author Topic: Fault code p0030  (Read 200 times)

Offline Ant b

  • Always Involved
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 70
Fault code p0030
« on: November 12, 2017, 10:28:28 PM »
Hello I fitted a decat 2 days ago and after a 10 min drive the engine light came on so reset it then again 10 min later came on again,isn’t the code the top senser that dosent normally have an issue with decats.
It never came on before,and it undone out of the old downpipe fine so I don’t think I broke it,
I’ve checked the plug and that’s fine.
Is my only option to buy a new one.
red mk5 gti ks05 fak,ram air intake,3” downpipe,dv+,coilovers and depos projectors

Offline Pudding

  • Just look at my post count
  • ******
  • Thank You
  • -Given: 2
  • -Receive: 250
  • Posts: 3194
Re: Fault code p0030
« Reply #1 on: November 13, 2017, 10:07:53 AM »
No it's the second sensor seeing too much oxygen in the exhaust.   If the primary sensor failed, you would know about it.  It would run like a sack of hammered crap.
Black Edition 30 with manually selected cogs, a beefier clutch, some extra boost and them Whiteline thingies, otherwise standard.

Offline Ant b

  • Always Involved
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 70
Re: Fault code p0030
« Reply #2 on: November 13, 2017, 03:42:50 PM »
It’s says bank 1 senser 1 isn’t that pre,it’s never come on that soon in any other cars tho if it is post
https://s20.postimg.org/fyh8nnjul/2_C1_D5430-_C437-4_A57-8_D87-3_B8175802_CE6.jpg
red mk5 gti ks05 fak,ram air intake,3” downpipe,dv+,coilovers and depos projectors

Offline lukemk5gti

  • Just look at my post count
  • ******
  • Thank You
  • -Given: 28
  • -Receive: 119
  • Posts: 1805
    • Email
  • My Ride: http://www.mk5golfgti.co.uk/forum/index.php?PHPSESSID=u1stcdv9inqfd9dq0hk7582q26&/topic,89715.msg907250.html#msg907250
Re: Fault code p0030
« Reply #3 on: November 13, 2017, 03:44:24 PM »

Offline Pudding

  • Just look at my post count
  • ******
  • Thank You
  • -Given: 2
  • -Receive: 250
  • Posts: 3194
Re: Fault code p0030
« Reply #4 on: November 13, 2017, 04:13:17 PM »
It’s says bank 1 senser 1 isn’t that pre,it’s never come on that soon in any other cars tho if it is post
https://s20.postimg.org/fyh8nnjul/2_C1_D5430-_C437-4_A57-8_D87-3_B8175802_CE6.jpg

Yeah that is the primary sensor.  Your scan tool doesn't say what the error is specifically.  Short to ground, no signal etc etc.......but it's the heater circuit side of it at fault.  The sensor side is probably OK.   Either way you will need to check the wiring / fuses or replace the sensor if they are OK.
Black Edition 30 with manually selected cogs, a beefier clutch, some extra boost and them Whiteline thingies, otherwise standard.

Offline dronners

  • Always Involved
  • ****
  • Thank You
  • -Given: 6
  • -Receive: 33
  • Posts: 310
Re: Fault code p0030
« Reply #5 on: November 13, 2017, 05:18:52 PM »
i had this code on my old car..  (a fiesta)  it means the heater circuit in the sensors died for some reason or another.  tbh just disturbing an old sensor could of killed it.  it used to cause some slight hesitation on my old car so probably best to get it replaced

Offline Ant b

  • Always Involved
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 70
Re: Fault code p0030
« Reply #6 on: November 13, 2017, 09:33:36 PM »
It’s says bank 1 senser 1 isn’t that pre,it’s never come on that soon in any other cars tho if it is post
https://s20.postimg.org/fyh8nnjul/2_C1_D5430-_C437-4_A57-8_D87-3_B8175802_CE6.jpg

Yeah that is the primary sensor.  Your scan tool doesn't say what the error is specifically.  Short to ground, no signal etc etc.......but it's the heater circuit side of it at fault.  The sensor side is probably OK.   Either way you will need to check the wiring / fuses or replace the sensor if they are OK.

I’ve checked all the wiring etc,it was all fine before tho
red mk5 gti ks05 fak,ram air intake,3” downpipe,dv+,coilovers and depos projectors

Offline Pudding

  • Just look at my post count
  • ******
  • Thank You
  • -Given: 2
  • -Receive: 250
  • Posts: 3194
Re: Fault code p0030
« Reply #7 on: November 14, 2017, 10:23:25 AM »
It’s says bank 1 senser 1 isn’t that pre,it’s never come on that soon in any other cars tho if it is post
https://s20.postimg.org/fyh8nnjul/2_C1_D5430-_C437-4_A57-8_D87-3_B8175802_CE6.jpg

Yeah that is the primary sensor.  Your scan tool doesn't say what the error is specifically.  Short to ground, no signal etc etc.......but it's the heater circuit side of it at fault.  The sensor side is probably OK.   Either way you will need to check the wiring / fuses or replace the sensor if they are OK.

I’ve checked all the wiring etc,it was all fine before tho

Did you disconnect the sensor plug on the bulkhead and turn the probe and harness together as a unit, or did you bind the wires twisting the probe out?

Either way, it's busted.  It may pass a visual inspection, but the ECU is god, and he/she decrees it's f'cked and needs replacing.
Black Edition 30 with manually selected cogs, a beefier clutch, some extra boost and them Whiteline thingies, otherwise standard.

Offline Ant b

  • Always Involved
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 70
Re: Fault code p0030
« Reply #8 on: November 14, 2017, 05:57:41 PM »
Yeah unplugged the harness and twisted togeather,looks like I need a new senser then
red mk5 gti ks05 fak,ram air intake,3” downpipe,dv+,coilovers and depos projectors