MK5 Golf GTI

All Things Mk5 => Mk5 General Area => Topic started by: Jons1001 on April 30, 2021, 05:35:24 pm

Title: Power steering control module fault
Post by: Jons1001 on April 30, 2021, 05:35:24 pm
Hi all, today I replaced the ignition switch on my mk5 gti as I had five fault codes relating to it aswell as some strange electrical goings on. All done and codes cleared but now the following has appeared;

(https://i.postimg.cc/zf8JPDSG/Screenshot-2021-04-30-17-30-01-021-com-voltasit-obdeleven.jpg) (https://postimg.cc/Bj79j0Vr)

Now is this something I can sort? Power steering appears to be working fine, also esp/traction control. I've reset the code but it's come back again, no lights on the dash though.
Title: Re: Power steering control module fault
Post by: Pudding on May 01, 2021, 12:24:17 am
Pull the battery for at least 30 mins, or pull it and touch the negative & positive cable ends together to clear any capacitive memory.

If the fault remains, I would get it investigated a bit deeper with a more in-depth scan tool, like VCDS.

You shouldn't ever get steering faults, in spite of how the car feels to drive. 

It usually starts with an amber steering wheel light on the dash when it's defcon 3, then elevates to a red light when it's defcon 1 and rack replacement is imminent.

FWIW, rack failure isn't unusual on MK5s, especially if it's a Gen 1 or Gen 2 rack.  The cure is to fit a Gen 3 rack from a MK6, which also needs a new (£100) harness.  That is also the official VW fix.

Title: Re: Power steering control module fault
Post by: Jons1001 on May 01, 2021, 06:00:51 am
Pull the battery for at least 30 mins, or pull it and touch the negative & positive cable ends together to clear any capacitive memory.

If the fault remains, I would get it investigated a bit deeper with a more in-depth scan tool, like VCDS.

You shouldn't ever get steering faults, in spite of how the car feels to drive. 

It usually starts with an amber steering wheel light on the dash when it's defcon 3, then elevates to a red light when it's defcon 1 and rack replacement is imminent.

FWIW, rack failure isn't unusual on MK5s, especially if it's a Gen 1 or Gen 2 rack.  The cure is to fit a Gen 3 rack from a MK6, which also needs a new (£100) harness.  That is also the official VW fix.

Cheers Pudding, have done some more investigation myself and isn't the steering control module slap bang under the ignition switch which I replaced? Thinking along the lines of something may have been knocked etc.
Title: Re: Power steering control module fault
Post by: Jons1001 on May 01, 2021, 06:51:10 am
Pull the battery for at least 30 mins, or pull it and touch the negative & positive cable ends together to clear any capacitive memory.

If the fault remains, I would get it investigated a bit deeper with a more in-depth scan tool, like VCDS.

You shouldn't ever get steering faults, in spite of how the car feels to drive. 

It usually starts with an amber steering wheel light on the dash when it's defcon 3, then elevates to a red light when it's defcon 1 and rack replacement is imminent.

FWIW, rack failure isn't unusual on MK5s, especially if it's a Gen 1 or Gen 2 rack.  The cure is to fit a Gen 3 rack from a MK6, which also needs a new (£100) harness.  That is also the official VW fix.

Cheers Pudding, have done some more investigation myself and isn't the steering control module slap bang under the ignition switch which I replaced? Thinking along the lines of something may have been knocked etc. as just seems too much of a coincidence that it suddenly appears immediately after changing the ignition switch. Also read that the supply wiring comes from under the driver's side headlight which is also an area I was messing around in yesterday (changing indicator bulb).
Title: Re: Power steering control module fault
Post by: Jons1001 on May 07, 2021, 07:40:28 am
So have driven a further 500 miles with no issues/lights on dash but a scan with obdeleven still shows a fault with the steering module. Took off the steering wheel plastics and everything seems ok, connection is tight etc.

Anyone have any ideas what to do next? As I say it just seems too much of a coincidence for it to fail just after changing the ignition switch which is directly above.

Just out of interest how much is supply/fit of a new steering rack?

Edit : Just found this old topic where a couple of people had this code AFTER having a new steering rack fitted.

https://www.mk5golfgti.co.uk/forum/index.php?topic=82305.15

In this case it needed coding to a new gen 3 rack, which doesn't really help me but could it perhaps have been knocked when doing the ignition switch which has caused some electrical gremlins etc? if so where do i start, anything i can check with obdeleven?