Make a donation

Author Topic: Air Con not working, please help! (1.9 tdi)  (Read 1128 times)

Offline bigmunquazi

  • Can't Read PM's Yet!
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 7
Air Con not working, please help! (1.9 tdi)
« on: May 26, 2019, 02:46:51 pm »
My aircon has been blowing hot air for a long time now, always thought might need a regas as I've never done it in 5 years of owning the car. Went yesterday for regas, but no difference!

Started investigating what the issue could be online etc and looking at the car, but still not entirely sure. Been spending a lot on repairs lately so want to make sure I find out the issue and spend least amount possible...thinking it could either be the air con pressure switch or air con compressor, perhaps fan involved, you guys know better than me  :signLOL:

Issues:
Car is Golf mk5 1.9 TDI 2007
Air con blows hot air and does not turn on
I've checked all my fuses are fine
Checked under the hood and with air-con on (eco off), the fans at the front do not engage after 30secs-1min, they don't start at all at any point
I can not tell if the compressor is working or not, the belt is moving around it but that's all I know, took two videos of it to show (car on:
&feature=youtu.be car off:
&feature=youtu.be)
Also just looking at pics of the compressors online compared to mine could something be missing off mine, the front plate thing? (after further inspection it might be this compressor looks similar): https://i.ebayimg.com/images/g/6FUAAOSwgppbYxKG/s-l1600.jpg)

That's all the information I've got really, can't see sticker to find compressor model, also don't know how to check if its the switch...hoping it's the switch as that's cheaper to change.
Can anyone tell if my compressor is buggered from the vid? Sound like compressor or switch in your opinion? thanks guys. Really want to order some parts and look to get it sorted asap as it's heating up now and I have already spent money on regassing  :driver:


« Last Edit: May 26, 2019, 03:30:29 pm by bigmunquazi »

Offline bigmunquazi

  • Can't Read PM's Yet!
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 7
Re: Air Con not working, please help! (1.9 tdi)
« Reply #1 on: May 27, 2019, 03:47:11 pm »
bump

Offline Wadgti

  • Taking part
  • ***
  • Thank You
  • -Given: 2
  • -Receive: 0
  • Posts: 32
Re: Air Con not working, please help! (1.9 tdi)
« Reply #2 on: May 27, 2019, 04:18:26 pm »
Just got mines done yesterday - not sure how the fans works with aircon someone else could perhaps fill in.

If you can scan it  - will tell you whats wrong - mines was a/c gas low however I do suspect I have a leak where the pressure switch is.

When you switch on the air con should should feel a small jolt on idle and revs should pick up by about 60 revs and you know the compressor is running. IF the system is low I don't think the compressor runs.


I bet it will be low a/c and you will probs have a leak like mines - from what ive read its common on the mk5's

Offline bigmunquazi

  • Can't Read PM's Yet!
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 7
Re: Air Con not working, please help! (1.9 tdi)
« Reply #3 on: May 28, 2019, 09:28:32 pm »
Just got mines done yesterday - not sure how the fans works with aircon someone else could perhaps fill in.

If you can scan it  - will tell you whats wrong - mines was a/c gas low however I do suspect I have a leak where the pressure switch is.

When you switch on the air con should should feel a small jolt on idle and revs should pick up by about 60 revs and you know the compressor is running. IF the system is low I don't think the compressor runs.


I bet it will be low a/c and you will probs have a leak like mines - from what ive read its common on the mk5's

thanks for the input! but I've literally regassed it the other day, which brought to light the issue that it isn't working...my idle revs don't change and no indication of the compressor activating. They said there was no leak when I got the regas, it filled up to the max amount of refrigerant fine.

Offline mo

  • Always Involved
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 14
  • Posts: 231
    • Email
Re: Air Con not working, please help! (1.9 tdi)
« Reply #4 on: May 29, 2019, 12:29:51 pm »
Replacing the pressure switch is usually the first port of call for aircon loss.
2007 Ed30 Superchips Bluefin Stg 1
RNS510 & MDI

Offline Lucky ducky

  • Always Involved
  • ****
  • Thank You
  • -Given: 30
  • -Receive: 3
  • Posts: 113
Re: Air Con not working, please help! (1.9 tdi)
« Reply #5 on: May 29, 2019, 12:50:17 pm »
I'm in the same boat.. Did a obdeleven scan which threw up fault low refrigerant pressure so took it to my local guy he used his VCDS and came back with the pressure sensor switch faulty which strangely never showed up on my OBDeleven scan.... So fingers arms legs crossed that it's just the pressure sensor...

Offline majoroson

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
Re: Air Con not working, please help! (1.9 tdi)
« Reply #6 on: July 20, 2021, 05:37:14 pm »
I prefer an air conditioner over a fan, to be honest. Where I’m from, a fan won’t save you from humidity and high temperature. I think the only benefit fan has is that it’s harder to break than the aircons. I had several issues with my air conditioner, and it’s really expensive to fix them. I tried once to clean it myself, but it went horribly wrong, and since then, I only ask professionals for help. But, when the aircon broke twice in one week, that’s when I couldn’t handle it anymore and decided to search on the internet how to fix it. Luckily, I ran into a nice website with a lot of information about aircons and how to fix them    them. After reading everything about my issue, I was able to fix my issue, and now my aircon operates stupendously.
« Last Edit: July 27, 2021, 12:36:01 pm by majoroson »

Online mjmallia

  • Always Involved
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 17
  • Posts: 224
Re: Air Con not working, please help! (1.9 tdi)
« Reply #7 on: July 21, 2021, 08:03:31 am »
Mine had an issue when I bought it, where it had not been gassed up in a while and blew hot air.  Had it gassed and it worked for a while, but got worse again as the air/moisture had its toll on the compressor eventually from being empty for so long.

I bought a new Denso compressor and changed the dryer in the condenser before a test/regas and it has been fine ever since.

NOTE: When the aircon is turned on, both radiator fans should turn on.

Once it is up and running leave it on all year round, even to warm the car in winter.........The gas/oil keeps the seals supple in the compressor, and get it re-gassed every two years (10-20% lost each year through natural losses)
« Last Edit: July 21, 2021, 08:06:56 am by mjmallia »
Mike


S3 8L ---- Lupo GTI ---- Golf Mk4 GT TDI ----  A4 B6 Sline ---- Golf Mk5 GTI